スポンサーサイト


    上記の広告は1ヶ月以上更新のないブログに表示されています。
    新しい記事を書く事で広告が消せます。





    Androidでsupport-v4(SupportPackage)を使いたい



    ■Androidでsupport-v4(SupportPackage)を使いたい

    いつものように、"Notification"の"setLatestEventInfo"を使おうとしたら、
    Notification.setLatestEventInfo
    ↑こんな感じで怒られた。どうやら非推奨らしい

    どうしよう、と調べたら、最近では"NotificationCompat.Builder"を
    使うのがいいらしい。古いSDKに対応するにはこれ。↓(参考サイト)
    http://dev.classmethod.jp/smartphone/android/android-tips-23-android4-1-notification-style/

    ところが、この"NotificationCompat.Builder"を使うには「SupportPackage」を使う、
    とサラッと出てくるのだが、なんだそれ?義務教育で習ってないぞ。

    さらに調べてみると、目的の"SupportPackage"を使うには、「android-support-v4.jar」が必要らしい。
    これがどこにあるのかっつーと、
    「android-sdk-windows」-「extras」-「android」-「support」-「v4」
    のフォルダ中にあります。(android-sdk-windowsより上は、任意のフォルダ)

    2013011301.png



    "android-support-v4.jar"をeclipseのプロジェクトの中の「libs」フォルダにコピーして、
    ビルド・パスの構成、からjarを追加します。

    2013011302.png


    改めて「NotificationCompat.Builder」を使うとエラーがでないです
    (android.support.v4.app.NotificationCompat)がインポートされます。

    スポンサーサイト





    コメントの投稿

    非公開コメント

    カテゴリ
    検索フォーム
    メールフォーム

    名前:
    メール:
    件名:
    本文:

    お世話になっている書籍達




















    リンク



    最新記事
    月別アーカイブ
    最新コメント
    プロフィール

    yukinori110

    Author:yukinori110
    Androidってなに?Javaってなに?というレベルから勉強してます。

    上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。